Cygwin (1.5.21-2)

  • ページ: 動作報告
  • 投稿者: kuroky?
  • 状態: 完了
  • ptetexバージョン:20060827
  • 投稿日: 2006-08-28 (月) 17:19:47

必要パッケージ

my_option

### (推奨) 既にライブラリが存在すれば、それを使う
CONF_OPTION=" --with-system-zlib"
CONF_OPTION=" --with-system-pnglib"
CONF_OPTION=" --with-system-gd"
CONF_OPTION=" --with-system-ncurses"
### (推奨) 使わないツールを除外する(コンパイル時間を節約)
CONF_OPTION=" --without-dviljk"
CONF_OPTION=" --without-info"
CONF_OPTION=" --without-texi2html"
CONF_OPTION=" --without-texinfo"
### ptex/platex コマンドの入出力文字コードを指定(ディフォルトは EUC)
### 入出力文字コードをシフト JIS にする
KANJI_CODE=SJIS
### xdvi のツールキットを指定する
CONF_OPTION=" --with-xdvi-x-toolkit=xaw3d"

メッセージ

platex は正常なようだが,latex の コンパイルに失敗している (以前起こった状況に似ているようだ).

$ which latex
/usr/local/teTeX/bin/latex
$ latex -v
$ (↑無反応)

  • 状況を適切に伝えるのはむずかしいのだが,補足すると,動作報告/25 と近い状況だと思っていただくのがよいと思う.make test も無事終了するのだが,できあがった testpage.dvi (<- とかそんな名前だったはず) は真っ白である.実験をした機材は,当方が 3.20060727-1 バイナリを正常に作ったマシン・当時の構成と同一である. -- kuroky? 2006-08-29 (火) 00:20:43
  • 20060815 でも試しましたが,latex はおかしいままです.-- kuroky? 2006-08-31 (木) 16:41:16
  • 趣旨がよくわからないのですが、cygwin がまたおかしくなったという報告なのでしょうか。それとも ptetex3 が 7/27 と 8/15 の間でおかしくなったということでしょうか。 -- 土村? 2006-08-31 (木) 17:38:30
  • `Cygwin' のヴァージョンは変わっていないので,7/27 と 8/15 の間で状況が変わってしまったのではないかと疑っています.ただ,再度 20060727 をコンパイルするという原因追及の第一歩を踏み出しておらず,ひとまず報告しておくことしかできないのは申し訳ないです.動作報告/25 のときも,うまくいったりいかなかったりを往復したので,まだ根本解決はしていないのではないか,というところも疑っています. -- kuroky? 2006-08-31 (木) 23:14:52
  • 動作報告/25 で成功した cygwin 環境で 8/30 版が成功しました。teTeX-3.0 を単独で make して latex がおかしければ、報告先は cygwin なり teTeX の開発者のほうがよいような気もします。 -- 土村? 2006-09-01 (金) 10:55:26
  • 成功報告ありがとうございます.Cygwin をリフレッシュするなど,解決策を探っていこうと思います. -- kuroky? 2006-09-01 (金) 14:52:03
  • Cygwin をまっさらにアンインストール & 削除して,再インストールした後,ptetex3-20060918 をコンパイルしたらうまくいきました.-- kuroky? 2006-10-04 (水) 15:57:50


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2006-10-04 (水) 15:57:52 (4617d)