OpenBSD4.5 -stable(amd64)

  • ページ: 動作報告
  • 投稿者: chocolat?
  • 状態: 小さな不具合
  • ptetexバージョン:20090607
  • 投稿日: 2009-06-09 (火) 23:51:56

必要パッケージ

bash gmake

my_option

JAPANESE=international
KANJI_CODE=EUC
PLATEX209=no

XDVI=echo

EXTRA_TRUETYPE="/usr/local/lib/X11/fonts/mplus;/usr/local/lib/X11/fonts/sazanami;/usr/local/lib/X11/fonts/ja;/usr/local/lib/X11/fonts/ghostscript;/usr/X11R6/lib/X11/fonts/TTF"
EXTRA_OPENTYPE="/usr/X11R6/lib/X11/fonts/OTF"

CPPFLAGS="-I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/libpng"
LDFLAGS="-L/usr/local/lib"
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
export LDFLAGS CPPFLAGS LD_LIBRARY_PATH

SYSTEM_FREETYPE2=yes

メッセージ

はじめにfreetypeをotvalidを有効にしてソースからインストールします。(詳しくは動作報告/125) freetypeのバージョンは2.3.9でした。
この状態でmake all0,make utfすると問題なく成功しますが、 次のmake babelの段階で次のようなエラーが出て、ストップしてしまいます。

Error: `pdfetex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini' possibly failed.
fmtutil: /var/tmp/ptetex3/share/texmf-var/web2c/latex.fmt installed.

###############################################################################
fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
  /var/tmp/ptetex3/share/texmf-var/web2c
for details.
###############################################################################

This is a summary of all `failed' messages and warnings: 
`pdfetex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini' possibly failed.
*** Error code 1

Stop in テフのディレクトリ/ptetex3-20090607 (line 71 of Makefile).

さらに、make testの段階でも、次のエラーが出てストップするので、my_optionに「XDVI=echo」を追加してなんとか やりすごしました。

finishing...
`which bash` ./8test.sh
------------------------------------------------------------------------
[reading]    ./my_option
-----------------------------
[latex] test
./8test.sh: line 33:  9076 Segmentation fault      (core dumped) $@ 2> /dev/null
/var/tmp/ptetex3/bin/xdvi -debug 8 testpage.dvi
Warning: locale not supported by C library, locale unchanged
KPATHSEA_DEBUG = 0
xdvik 22.84.13 j1.41-ptetex3 (Xaw toolkit), kpathsea: kpathsea version 3.5.6
configured with: ppi=600 shrink=8 mfmode=<NONE> alt_font=cmr10 paper=a4
./8test.sh: line 33:  4850 Segmentation fault      (core dumped) $@
*** Error code 1

 Stop in テフのディレクトリ/ptetex3-20090506 (line 77 of Makefile).

結局、make all0, make utf, make testのみを行い、 最後にmake installをすると以下のメッセージが出ます。

finishing ...
Error: `pdfetex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini' possibly failed.
Error: `pdfetex -ini  -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini' possibly failed.
Error: `omega -ini  -jobname=lambda -progname=lambda lambda.ini' possibly failed.
Error: `aleph -ini  -jobname=lamed -progname=lamed *lambda.ini' possibly failed.
Error: `ptex -ini  -jobname=platex -progname=platex --kanji=default platex.ini' possibly failed.

###############################################################################
fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
  /usr/local/teTeX/share/texmf-var/web2c
for details.
###############################################################################

This is a summary of all `failed' messages and warnings:
`pdfetex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini' possibly failed.
`pdfetex -ini  -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini' possibly  failed.
`omega -ini  -jobname=lambda -progname=lambda lambda.ini' possibly failed.
`aleph -ini  -jobname=lamed -progname=lamed *lambda.ini' possibly failed.
`ptex -ini  -jobname=platex -progname=platex --kanji=default platex.ini' possibly failed.
*** Error code 1
 
 Stop in テフのディレクトリ/ptetex3-20090607 (line 79 of Makefile).

また、今回のptetexのバージョンは20090607でしたが、20090507,20090506でも同様のエラーが出ました。
なおOpenBSD4.5-stableのi386では上記のエラーは出ず、問題なく完了します。


  • ありがとうございます。babel の件は調査してみます。xdvi は不思議というか、JAPANESE=international ならば日本語版は pxdvi のはずですよね。手元で再現しないおので、原因がどうしたらわかるか、ちょっと頭が痛いです。 -- 土村 2009-06-10 (水) 09:25:05
  • MacOS 10.5.7でも上記と同じエラーが出ます。 -- 若葉 2009-06-10 (水) 13:44:37
  • 本日版で xdvi 以外の問題は解決(というか先延ばし)したと思います。 -- 土村 2009-06-10 (水) 17:12:56
  • 迅速な対応ありがとうございます。20090610バージョンでXDVI=echoで問題なく成功しました。XDVIの問題はamd64特有の問題のようで、i386ではこのエラーは出ません。しかし、通常使用では特に問題ないと思われるので、とりあえずこれは置いといてptexliveへ移行したいと思います。本当にありがとうございました。 -- chocolat 2009-06-11 (木) 16:55:49
  • ptexliveの動作報告56からリンクするようにアンカーを張りました。内容は一切変更してません。 -- chocolat 2009-11-18 (水) 13:46:17


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-11-18 (水) 13:46:17 (2921d)